import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+(\\[-|\\{\\+).*$";
final String string = "@@ -11 +11 @@ delta dAddressBook {\n"
+ " private String [-addressA;-]{+address;+}\n"
+ "@@ -13 +13 @@ delta dAddressBook {\n"
+ " public [-AddressBookEntryB()-]{+AddressBookEntry()+} {\n"
+ "@@ -39,0 +40,4 @@ delta dAddressBook {\n\n"
+ " {+public void setAddress(String address) {+}\n"
+ "{+ this.address = address;+}\n"
+ "{+ }+}\n"
+ "@@ -45,2 +48,0 @@ delta dAddressBook {\n"
+ "[- import br.unb.cic.iris.core.exception.EmailException;-]\n"
+ "[- import br.unb.cic.iris.core.model.AddressBookEntry;-]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}