const regex = /.+(\[-|\{\+).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.+(\\[-|\\{\\+).*$', 'gm')
const str = `@@ -11 +11 @@ delta dAddressBook {
private String [-addressA;-]{+address;+}
@@ -13 +13 @@ delta dAddressBook {
public [-AddressBookEntryB()-]{+AddressBookEntry()+} {
@@ -39,0 +40,4 @@ delta dAddressBook {
{+public void setAddress(String address) {+}
{+ this.address = address;+}
{+ }+}
@@ -45,2 +48,0 @@ delta dAddressBook {
[- import br.unb.cic.iris.core.exception.EmailException;-]
[- import br.unb.cic.iris.core.model.AddressBookEntry;-]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}