use strict;
my $str = '@@ -11 +11 @@ delta dAddressBook {
private String [-addressA;-]{+address;+}
@@ -13 +13 @@ delta dAddressBook {
public [-AddressBookEntryB()-]{+AddressBookEntry()+} {
@@ -39,0 +40,4 @@ delta dAddressBook {
{+public void setAddress(String address) {+}
{+ this.address = address;+}
{+ }+}
@@ -45,2 +48,0 @@ delta dAddressBook {
[- import br.unb.cic.iris.core.exception.EmailException;-]
[- import br.unb.cic.iris.core.model.AddressBookEntry;-]
';
my $regex = qr/.+(\[-|\{\+).*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}