#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:<(p)([\s\w='":;]+)?>)(.*)(?:<\/(p)>)"
Local $sString = "<!DOCTYPE html>" & @CRLF & _
"<html lang="en">" & @CRLF & _
" <head>" & @CRLF & _
" <meta charset="UTF-8">" & @CRLF & _
" <meta http-equiv="X-UA-Compatible" content="IE=edge">" & @CRLF & _
" <meta name="viewport" content="width=device-width, initial-scale=1.0">" & @CRLF & _
" <title>Document</title>" & @CRLF & _
" </head>" & @CRLF & _
" <body>" & @CRLF & _
" <div>" & @CRLF & _
" Sono un div" & @CRLF & _
" <p class="data" style="color: red;">Sono un paragrafo </p>" & @CRLF & _
" <p>Altro paragrafo </p>" & @CRLF & _
" <span>Uno span </span>" & @CRLF & _
" <a href="">Un link </a>" & @CRLF & _
" <button>Un bottone </button>" & @CRLF & _
" </div>" & @CRLF & _
" </body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")