# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:<(p)([\s\w='\":;]+)?>)(.*)(?:<\/(p)>)"
test_str = ("<!DOCTYPE html>\n"
"<html lang=\"en\">\n"
" <head>\n"
" <meta charset=\"UTF-8\">\n"
" <meta http-equiv=\"X-UA-Compatible\" content=\"IE=edge\">\n"
" <meta name=\"viewport\" content=\"width=device-width, initial-scale=1.0\">\n"
" <title>Document</title>\n"
" </head>\n"
" <body>\n"
" <div>\n"
" Sono un div\n"
" <p class=\"data\" style=\"color: red;\">Sono un paragrafo </p>\n"
" <p>Altro paragrafo </p>\n"
" <span>Uno span </span>\n"
" <a href=\"\">Un link </a>\n"
" <button>Un bottone </button>\n"
" </div>\n"
" </body>\n"
"</html>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.