import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<(p)([\\s\\w='\":;]+)?>)(.*)(?:<\\/(p)>)";
final String string = "<!DOCTYPE html>\n"
+ "<html lang=\"en\">\n"
+ " <head>\n"
+ " <meta charset=\"UTF-8\">\n"
+ " <meta http-equiv=\"X-UA-Compatible\" content=\"IE=edge\">\n"
+ " <meta name=\"viewport\" content=\"width=device-width, initial-scale=1.0\">\n"
+ " <title>Document</title>\n"
+ " </head>\n"
+ " <body>\n"
+ " <div>\n"
+ " Sono un div\n"
+ " <p class=\"data\" style=\"color: red;\">Sono un paragrafo </p>\n"
+ " <p>Altro paragrafo </p>\n"
+ " <span>Uno span </span>\n"
+ " <a href=\"\">Un link </a>\n"
+ " <button>Un bottone </button>\n"
+ " </div>\n"
+ " </body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}