const regex = /(?:<(p)([\s\w='":;]+)?>)(.*)(?:<\/(p)>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:<(p)([\\s\\w=\'":;]+)?>)(.*)(?:<\\\/(p)>)', 'g')
const str = `<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<title>Document</title>
</head>
<body>
<div>
Sono un div
<p class="data" style="color: red;">Sono un paragrafo </p>
<p>Altro paragrafo </p>
<span>Uno span </span>
<a href="">Un link </a>
<button>Un bottone </button>
</div>
</body>
</html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}