using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<(p)([\s\w='"":;]+)?>)(.*)(?:<\/(p)>)";
string input = @"<!DOCTYPE html>
<html lang=""en"">
<head>
<meta charset=""UTF-8"">
<meta http-equiv=""X-UA-Compatible"" content=""IE=edge"">
<meta name=""viewport"" content=""width=device-width, initial-scale=1.0"">
<title>Document</title>
</head>
<body>
<div>
Sono un div
<p class=""data"" style=""color: red;"">Sono un paragrafo </p>
<p>Altro paragrafo </p>
<span>Uno span </span>
<a href="">Un link </a>
<button>Un bottone </button>
</div>
</body>
</html>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}