# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*Download:\s{3,5}\K\d{1,3}\.\d{0,2}(?= Mbps)//gm;t' <<< ".net, asp.net hello. world, c#"