const regex = new RegExp('^.*Download:\\s{3,5}\\K\\d{1,3}\\.\\d{0,2}(?= Mbps)', 'gm')
const str = `.net, asp.net hello. world, c#`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);