re = /^.*Download:\s{3,5}\K\d{1,3}\.\d{0,2}(?= Mbps)/m
str = '.net, asp.net hello. world, c#'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result