$re = '~^.*Download:\s{3,5}\K\d{1,3}\.\d{0,2}(?= Mbps)~m';
$str = '.net, asp.net hello. world, c#';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;