package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)*((#\d+)|((box|bin)[-. \/\\]?\d+)|(.*p[ \.]? ?(o|0)[-. \/\\]? *-?((box|bin)|b|(num)?\d+))|(p(ost)? *(o(ff(ice)?)?)? *((box|bin)|b)? *\d+)|(p *-?\/?(o)? *-?box)|post office box|((box|bin)|b) *(number|num)? *\d+|(num|number) *\d+)\d`)
var str = `PO Box 234, Suburb, ACT, Australia, 5678
123 Some Street
PO BOX 234 Suburb, ACT, Australia, 2342
po box 345, somehwere, state, country, postcode
post office box 2343, nothing ,no state, country , 345
345 smith st, po box 345, no place, no country, 3454
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}