import re
regex = re.compile(r"*((#\d+)|((box|bin)[-. \/\\]?\d+)|(.*p[ \.]? ?(o|0)[-. \/\\]? *-?((box|bin)|b|(num)?\d+))|(p(ost)? *(o(ff(ice)?)?)? *((box|bin)|b)? *\d+)|(p *-?\/?(o)? *-?box)|post office box|((box|bin)|b) *(number|num)? *\d+|(num|number) *\d+)\d", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("PO Box 234, Suburb, ACT, Australia, 5678\n\n"
"123 Some Street\n\n"
"PO BOX 234 Suburb, ACT, Australia, 2342\n\n"
"po box 345, somehwere, state, country, postcode\n\n"
"post office box 2343, nothing ,no state, country , 345\n\n"
"345 smith st, po box 345, no place, no country, 3454\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")