import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "*((#\\d+)|((box|bin)[-. \\/\\\\]?\\d+)|(.*p[ \\.]? ?(o|0)[-. \\/\\\\]? *-?((box|bin)|b|(num)?\\d+))|(p(ost)? *(o(ff(ice)?)?)? *((box|bin)|b)? *\\d+)|(p *-?\\/?(o)? *-?box)|post office box|((box|bin)|b) *(number|num)? *\\d+|(num|number) *\\d+)\\d";
final String string = "PO Box 234, Suburb, ACT, Australia, 5678\n\n"
+ "123 Some Street\n\n"
+ "PO BOX 234 Suburb, ACT, Australia, 2342\n\n"
+ "po box 345, somehwere, state, country, postcode\n\n"
+ "post office box 2343, nothing ,no state, country , 345\n\n"
+ "345 smith st, po box 345, no place, no country, 3454\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}