const regex = /*((#\d+)|((box|bin)[-. \/\\]?\d+)|(.*p[ \.]? ?(o|0)[-. \/\\]? *-?((box|bin)|b|(num)?\d+))|(p(ost)? *(o(ff(ice)?)?)? *((box|bin)|b)? *\d+)|(p *-?\/?(o)? *-?box)|post office box|((box|bin)|b) *(number|num)? *\d+|(num|number) *\d+)\d/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('*((#\\d+)|((box|bin)[-. \\\/\\\\]?\\d+)|(.*p[ \\.]? ?(o|0)[-. \\\/\\\\]? *-?((box|bin)|b|(num)?\\d+))|(p(ost)? *(o(ff(ice)?)?)? *((box|bin)|b)? *\\d+)|(p *-?\\\/?(o)? *-?box)|post office box|((box|bin)|b) *(number|num)? *\\d+|(num|number) *\\d+)\\d', 'igm')
const str = `PO Box 234, Suburb, ACT, Australia, 5678
123 Some Street
PO BOX 234 Suburb, ACT, Australia, 2342
po box 345, somehwere, state, country, postcode
post office box 2343, nothing ,no state, country , 345
345 smith st, po box 345, no place, no country, 3454
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}