const regex = /(?:rgb(?:a|)\s*|#)(?:\(|)\s*(25[0-5]|2[0-4][0-9]|1[0-9]?[0-9]?|[1-9][0-9]?|[0-9]|[A-Fa-f0-9]{2}|[A-Fa-f0-9]{2})(?:\,|)\s*(25[0-5]|2[0-4][0-9]|1[0-9]?[0-9]?|[1-9][0-9]?|[0-9]|[A-Fa-f0-9]{2}|[A-Fa-f0-9]{2})(?:\,|)(?:\,|)\s*(25[0-5]|2[0-4][0-9]|1[0-9]?[0-9]?|[1-9][0-9]?|[0-9]|[A-Fa-f0-9]{2}|[A-Fa-f0-9]{2}).+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:rgb(?:a|)\\s*|#)(?:\\(|)\\s*(25[0-5]|2[0-4][0-9]|1[0-9]?[0-9]?|[1-9][0-9]?|[0-9]|[A-Fa-f0-9]{2}|[A-Fa-f0-9]{2})(?:\\,|)\\s*(25[0-5]|2[0-4][0-9]|1[0-9]?[0-9]?|[1-9][0-9]?|[0-9]|[A-Fa-f0-9]{2}|[A-Fa-f0-9]{2})(?:\\,|)(?:\\,|)\\s*(25[0-5]|2[0-4][0-9]|1[0-9]?[0-9]?|[1-9][0-9]?|[0-9]|[A-Fa-f0-9]{2}|[A-Fa-f0-9]{2}).+', 'gm')
const str = `
#3498db
rgb(231, 76, 60)
rgb(155, 89, 182)
rgba(46, 204, 113,1.0)
rgba ( 52, 152, 219,1.0)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}