$re = '/(?:rgb(?:a|)\s*|#)(?:\(|)\s*(25[0-5]|2[0-4][0-9]|1[0-9]?[0-9]?|[1-9][0-9]?|[0-9]|[A-Fa-f0-9]{2}|[A-Fa-f0-9]{2})(?:\,|)\s*(25[0-5]|2[0-4][0-9]|1[0-9]?[0-9]?|[1-9][0-9]?|[0-9]|[A-Fa-f0-9]{2}|[A-Fa-f0-9]{2})(?:\,|)(?:\,|)\s*(25[0-5]|2[0-4][0-9]|1[0-9]?[0-9]?|[1-9][0-9]?|[0-9]|[A-Fa-f0-9]{2}|[A-Fa-f0-9]{2}).+/m';
$str = '
#3498db
rgb(231, 76, 60)
rgb(155, 89, 182)
rgba(46, 204, 113,1.0)
rgba ( 52, 152, 219,1.0)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);