// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:rgb(?:a|)\s*|#)(?:\(|)\s*(25[0-5]|2[0-4][0-9]|1[0-9]?[0-9]?|[1-9][0-9]?|[0-9]|[A-Fa-f0-9]{2}|[A-Fa-f0-9]{2})(?:\,|)\s*(25[0-5]|2[0-4][0-9]|1[0-9]?[0-9]?|[1-9][0-9]?|[0-9]|[A-Fa-f0-9]{2}|[A-Fa-f0-9]{2})(?:\,|)(?:\,|)\s*(25[0-5]|2[0-4][0-9]|1[0-9]?[0-9]?|[1-9][0-9]?|[0-9]|[A-Fa-f0-9]{2}|[A-Fa-f0-9]{2}).+").unwrap();
let string = "
#3498db
rgb(231, 76, 60)
rgb(155, 89, 182)
rgba(46, 204, 113,1.0)
rgba ( 52, 152, 219,1.0)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}