use strict;
my $str = '
#3498db
rgb(231, 76, 60)
rgb(155, 89, 182)
rgba(46, 204, 113,1.0)
rgba ( 52, 152, 219,1.0)';
my $regex = qr/(?:rgb(?:a|)\s*|#)(?:\(|)\s*(25[0-5]|2[0-4][0-9]|1[0-9]?[0-9]?|[1-9][0-9]?|[0-9]|[A-Fa-f0-9]{2}|[A-Fa-f0-9]{2})(?:\,|)\s*(25[0-5]|2[0-4][0-9]|1[0-9]?[0-9]?|[1-9][0-9]?|[0-9]|[A-Fa-f0-9]{2}|[A-Fa-f0-9]{2})(?:\,|)(?:\,|)\s*(25[0-5]|2[0-4][0-9]|1[0-9]?[0-9]?|[1-9][0-9]?|[0-9]|[A-Fa-f0-9]{2}|[A-Fa-f0-9]{2}).+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}