#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\bOPUS(\b|\d)(?!.*[ ._-](\d{3,4}p))"
Local $sString = "# MATCH" & @CRLF & _
"Serie.S01E05.Magnum.Opus.Test.2160p.DSNP.WEB-DL.OPUS.2.0.DoVi.H.265-RlsGrp" & @CRLF & _
"Serie.S01E05.Magnum.Opus.2160p.DSNP.WEB-DL.OPUS.2.0.DoVi.H.265-RlsGrp" & @CRLF & _
"Serie.S01E05.Magnum.Opus.2160p.DSNP.WEB-DL.OPUS.DoVi.H.265-RlsGrp" & @CRLF & _
"Serie.S01E05.Magnum.Opus.720p.DSNP.WEB-DL.OPUS.DoVi.H.265-RlsGrp" & @CRLF & _
"" & @CRLF & _
"# DON'T MATCH" & @CRLF & _
"Serie.S01E05.Magnum.Opus.2160p.DSNP.WEB-DL.DDP.5.1.DoVi.H.265-RlsGrp" & @CRLF & _
"Serie.S01E05.Magnum.Opus.Test.1080p.DSNP.WEB-DL.DDP.5.1.DoVi.H.265-RlsGrp" & @CRLF & _
"Serie.S01E05.Magnum.Opus.Test.720p.DSNP.WEB-DL.DDP.5.1.DoVi.H.265-RlsGrp" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")