import re
regex = re.compile(r"\bOPUS(\b|\d)(?!.*[ ._-](\d{3,4}p))", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("# MATCH\n"
"Serie.S01E05.Magnum.Opus.Test.2160p.DSNP.WEB-DL.OPUS.2.0.DoVi.H.265-RlsGrp\n"
"Serie.S01E05.Magnum.Opus.2160p.DSNP.WEB-DL.OPUS.2.0.DoVi.H.265-RlsGrp\n"
"Serie.S01E05.Magnum.Opus.2160p.DSNP.WEB-DL.OPUS.DoVi.H.265-RlsGrp\n"
"Serie.S01E05.Magnum.Opus.720p.DSNP.WEB-DL.OPUS.DoVi.H.265-RlsGrp\n\n"
"# DON'T MATCH\n"
"Serie.S01E05.Magnum.Opus.2160p.DSNP.WEB-DL.DDP.5.1.DoVi.H.265-RlsGrp\n"
"Serie.S01E05.Magnum.Opus.Test.1080p.DSNP.WEB-DL.DDP.5.1.DoVi.H.265-RlsGrp\n"
"Serie.S01E05.Magnum.Opus.Test.720p.DSNP.WEB-DL.DDP.5.1.DoVi.H.265-RlsGrp\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")