use strict;
my $str = '# MATCH
Serie.S01E05.Magnum.Opus.Test.2160p.DSNP.WEB-DL.OPUS.2.0.DoVi.H.265-RlsGrp
Serie.S01E05.Magnum.Opus.2160p.DSNP.WEB-DL.OPUS.2.0.DoVi.H.265-RlsGrp
Serie.S01E05.Magnum.Opus.2160p.DSNP.WEB-DL.OPUS.DoVi.H.265-RlsGrp
Serie.S01E05.Magnum.Opus.720p.DSNP.WEB-DL.OPUS.DoVi.H.265-RlsGrp
# DON\'T MATCH
Serie.S01E05.Magnum.Opus.2160p.DSNP.WEB-DL.DDP.5.1.DoVi.H.265-RlsGrp
Serie.S01E05.Magnum.Opus.Test.1080p.DSNP.WEB-DL.DDP.5.1.DoVi.H.265-RlsGrp
Serie.S01E05.Magnum.Opus.Test.720p.DSNP.WEB-DL.DDP.5.1.DoVi.H.265-RlsGrp
';
my $regex = qr/\bOPUS(\b|\d)(?!.*[ ._-](\d{3,4}p))/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}