import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bOPUS(\\b|\\d)(?!.*[ ._-](\\d{3,4}p))";
final String string = "# MATCH\n"
+ "Serie.S01E05.Magnum.Opus.Test.2160p.DSNP.WEB-DL.OPUS.2.0.DoVi.H.265-RlsGrp\n"
+ "Serie.S01E05.Magnum.Opus.2160p.DSNP.WEB-DL.OPUS.2.0.DoVi.H.265-RlsGrp\n"
+ "Serie.S01E05.Magnum.Opus.2160p.DSNP.WEB-DL.OPUS.DoVi.H.265-RlsGrp\n"
+ "Serie.S01E05.Magnum.Opus.720p.DSNP.WEB-DL.OPUS.DoVi.H.265-RlsGrp\n\n"
+ "# DON'T MATCH\n"
+ "Serie.S01E05.Magnum.Opus.2160p.DSNP.WEB-DL.DDP.5.1.DoVi.H.265-RlsGrp\n"
+ "Serie.S01E05.Magnum.Opus.Test.1080p.DSNP.WEB-DL.DDP.5.1.DoVi.H.265-RlsGrp\n"
+ "Serie.S01E05.Magnum.Opus.Test.720p.DSNP.WEB-DL.DDP.5.1.DoVi.H.265-RlsGrp\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}