$re = '/\bOPUS(\b|\d)(?!.*[ ._-](\d{3,4}p))/mi';
$str = '# MATCH
Serie.S01E05.Magnum.Opus.Test.2160p.DSNP.WEB-DL.OPUS.2.0.DoVi.H.265-RlsGrp
Serie.S01E05.Magnum.Opus.2160p.DSNP.WEB-DL.OPUS.2.0.DoVi.H.265-RlsGrp
Serie.S01E05.Magnum.Opus.2160p.DSNP.WEB-DL.OPUS.DoVi.H.265-RlsGrp
Serie.S01E05.Magnum.Opus.720p.DSNP.WEB-DL.OPUS.DoVi.H.265-RlsGrp
# DON\'T MATCH
Serie.S01E05.Magnum.Opus.2160p.DSNP.WEB-DL.DDP.5.1.DoVi.H.265-RlsGrp
Serie.S01E05.Magnum.Opus.Test.1080p.DSNP.WEB-DL.DDP.5.1.DoVi.H.265-RlsGrp
Serie.S01E05.Magnum.Opus.Test.720p.DSNP.WEB-DL.DDP.5.1.DoVi.H.265-RlsGrp
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);