#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?!(.*mysite))((www|http|.*com).*)"
Local $sString = "www.facebook.com/fatymasphotography" & @CRLF & _
"sdasdsldslkd" & @CRLF & _
"asdsad" & @CRLF & _
"sdsd sd https://www.youtube.com/watch?v=4tZ-llzgLRI&list=UU0AE_22J0kAo30yjasaeFqw " & @CRLF & _
"sdas 12308=asda" & @CRLF & _
"https://vimeo.com/123098174" & @CRLF & _
"youtube.com/watch?v=4tZ-llzgLRI&list=UU0AE_22J0kAo30yjasaeFqw " & @CRLF & _
"" & @CRLF & _
"\.com" & @CRLF & _
"http://dev.axovel.com/exqzt/ " & @CRLF & _
"https://www.mysite.com/u/greenuniversetec.html" & @CRLF & _
"asodkasd 123/2323"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")