const regex = /(?!(.*mysite))((www|http|.*com).*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!(.*mysite))((www|http|.*com).*)', 'g')
const str = `www.facebook.com/fatymasphotography
sdasdsldslkd
asdsad
sdsd sd https://www.youtube.com/watch?v=4tZ-llzgLRI&list=UU0AE_22J0kAo30yjasaeFqw
sdas 12308=asda
https://vimeo.com/123098174
youtube.com/watch?v=4tZ-llzgLRI&list=UU0AE_22J0kAo30yjasaeFqw
\\.com
http://dev.axovel.com/exqzt/
https://www.mysite.com/u/greenuniversetec.html
asodkasd 123/2323`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}