using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!(.*mysite))((www|http|.*com).*)";
string input = @"www.facebook.com/fatymasphotography
sdasdsldslkd
asdsad
sdsd sd https://www.youtube.com/watch?v=4tZ-llzgLRI&list=UU0AE_22J0kAo30yjasaeFqw
sdas 12308=asda
https://vimeo.com/123098174
youtube.com/watch?v=4tZ-llzgLRI&list=UU0AE_22J0kAo30yjasaeFqw
\.com
http://dev.axovel.com/exqzt/
https://www.mysite.com/u/greenuniversetec.html
asodkasd 123/2323";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}