use strict;
my $str = 'www.facebook.com/fatymasphotography
sdasdsldslkd
asdsad
sdsd sd https://www.youtube.com/watch?v=4tZ-llzgLRI&list=UU0AE_22J0kAo30yjasaeFqw
sdas 12308=asda
https://vimeo.com/123098174
youtube.com/watch?v=4tZ-llzgLRI&list=UU0AE_22J0kAo30yjasaeFqw
\\.com
http://dev.axovel.com/exqzt/
https://www.mysite.com/u/greenuniversetec.html
asodkasd 123/2323';
my $regex = qr/(?!(.*mysite))((www|http|.*com).*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}