$re = '/(?!(.*mysite))((www|http|.*com).*)/';
$str = 'www.facebook.com/fatymasphotography
sdasdsldslkd
asdsad
sdsd sd https://www.youtube.com/watch?v=4tZ-llzgLRI&list=UU0AE_22J0kAo30yjasaeFqw
sdas 12308=asda
https://vimeo.com/123098174
youtube.com/watch?v=4tZ-llzgLRI&list=UU0AE_22J0kAo30yjasaeFqw
\\.com
http://dev.axovel.com/exqzt/
https://www.mysite.com/u/greenuniversetec.html
asodkasd 123/2323';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);