#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\w{3}\s{1}\w{3}\s{1}\d{2}\s{1}\d{2}\:\d{2}\:\d{2}\s{1}\d{4})?((\r||.|\n)*)(?=(\w{3}\s{1}\w{3}\s{1}\d{2}\s{1}\d{2}\:\d{2}\:\d{2}\s{1}\d{4}))"
Local $sString = "Tue Sep 14 08:57:47 2021" & @CRLF & _
"Thread 1 advanced to log sequence 186 (LGWR switch)" & @CRLF & _
" Current log# 2 seq# 186 mem# 0: D:\ORADB\DV1\REDO02A.LOG" & @CRLF & _
" Current log# 2 seq# 186 mem# 1: H:\ORADB\DV1\REDO02B.LOG" & @CRLF & _
"Tue Sep 14 09:07:40 2021" & @CRLF & _
"Thread 1 advanced to log sequence 187 (LGWR switch)" & @CRLF & _
" Current log# 3 seq# 187 mem# 0: D:\ORADB\DV1\REDO03A.LOG" & @CRLF & _
" Current log# 3 seq# 187 mem# 1: H:\ORADB\DV1\REDO03B.LOG" & @CRLF & _
"Tue Sep 14 09:22:09 2021" & @CRLF & _
"Thread 1 advanced to log sequence 188 (LGWR switch)" & @CRLF & _
" Current log# 4 seq# 188 mem# 0: D:\ORADB\DV1\REDO04A.LOG" & @CRLF & _
" Current log# 4 seq# 188 mem# 1: H:\ORADB\DV1\REDO04B.LOG" & @CRLF & _
"Tue Sep 14 09:38:03 2021" & @CRLF & _
"Thread 1 advanced to log sequence 189 (LGWR switch)" & @CRLF & _
" Current log# 1 seq# 189 mem# 0: D:\ORADB\DV1\REDO01A.LOG" & @CRLF & _
" Current log# 1 seq# 189 mem# 1: H:\ORADB\DV1\REDO01B.LOG"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")