import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w{3}\\s{1}\\w{3}\\s{1}\\d{2}\\s{1}\\d{2}\\:\\d{2}\\:\\d{2}\\s{1}\\d{4})?((\\r||.|\\n)*)(?=(\\w{3}\\s{1}\\w{3}\\s{1}\\d{2}\\s{1}\\d{2}\\:\\d{2}\\:\\d{2}\\s{1}\\d{4}))";
final String string = "Tue Sep 14 08:57:47 2021\n"
+ "Thread 1 advanced to log sequence 186 (LGWR switch)\n"
+ " Current log# 2 seq# 186 mem# 0: D:\\ORADB\\DV1\\REDO02A.LOG\n"
+ " Current log# 2 seq# 186 mem# 1: H:\\ORADB\\DV1\\REDO02B.LOG\n"
+ "Tue Sep 14 09:07:40 2021\n"
+ "Thread 1 advanced to log sequence 187 (LGWR switch)\n"
+ " Current log# 3 seq# 187 mem# 0: D:\\ORADB\\DV1\\REDO03A.LOG\n"
+ " Current log# 3 seq# 187 mem# 1: H:\\ORADB\\DV1\\REDO03B.LOG\n"
+ "Tue Sep 14 09:22:09 2021\n"
+ "Thread 1 advanced to log sequence 188 (LGWR switch)\n"
+ " Current log# 4 seq# 188 mem# 0: D:\\ORADB\\DV1\\REDO04A.LOG\n"
+ " Current log# 4 seq# 188 mem# 1: H:\\ORADB\\DV1\\REDO04B.LOG\n"
+ "Tue Sep 14 09:38:03 2021\n"
+ "Thread 1 advanced to log sequence 189 (LGWR switch)\n"
+ " Current log# 1 seq# 189 mem# 0: D:\\ORADB\\DV1\\REDO01A.LOG\n"
+ " Current log# 1 seq# 189 mem# 1: H:\\ORADB\\DV1\\REDO01B.LOG";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}