# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\w{3}\s{1}\w{3}\s{1}\d{2}\s{1}\d{2}\:\d{2}\:\d{2}\s{1}\d{4})?((\r||.|\n)*)(?=(\w{3}\s{1}\w{3}\s{1}\d{2}\s{1}\d{2}\:\d{2}\:\d{2}\s{1}\d{4}))"
test_str = ("Tue Sep 14 08:57:47 2021\n"
"Thread 1 advanced to log sequence 186 (LGWR switch)\n"
" Current log# 2 seq# 186 mem# 0: D:\\ORADB\\DV1\\REDO02A.LOG\n"
" Current log# 2 seq# 186 mem# 1: H:\\ORADB\\DV1\\REDO02B.LOG\n"
"Tue Sep 14 09:07:40 2021\n"
"Thread 1 advanced to log sequence 187 (LGWR switch)\n"
" Current log# 3 seq# 187 mem# 0: D:\\ORADB\\DV1\\REDO03A.LOG\n"
" Current log# 3 seq# 187 mem# 1: H:\\ORADB\\DV1\\REDO03B.LOG\n"
"Tue Sep 14 09:22:09 2021\n"
"Thread 1 advanced to log sequence 188 (LGWR switch)\n"
" Current log# 4 seq# 188 mem# 0: D:\\ORADB\\DV1\\REDO04A.LOG\n"
" Current log# 4 seq# 188 mem# 1: H:\\ORADB\\DV1\\REDO04B.LOG\n"
"Tue Sep 14 09:38:03 2021\n"
"Thread 1 advanced to log sequence 189 (LGWR switch)\n"
" Current log# 1 seq# 189 mem# 0: D:\\ORADB\\DV1\\REDO01A.LOG\n"
" Current log# 1 seq# 189 mem# 1: H:\\ORADB\\DV1\\REDO01B.LOG")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.