using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^0001[\s]*(.*?)[\s]*([\d,.]*)[\s]*(\d{6})";
string input = @"0001 Basic Salary 4,408.00 200801";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}