package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^0001[\s]*(.*?)[\s]*([\d,.]*)[\s]*(\d{6})`)
var str = `0001 Basic Salary 4,408.00 200801`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}