$re = '/^0001[\s]*(.*?)[\s]*([\d,.]*)[\s]*(\d{6})/m';
$str = '0001 Basic Salary 4,408.00 200801';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);