re = /^0001[\s]*(.*?)[\s]*([\d,.]*)[\s]*(\d{6})/m
str = '0001 Basic Salary 4,408.00 200801'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end