using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a>.*<\/a>)";
string input = @"asldjkgjasdkjgasdk
<a>test</a>lol
<a>am</a>
asdhjfgasdjkgdaskj
<a>bfasjdg as</a>
abab";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}