$re = '/(<a>.*<\/a>)/';
$str = 'asldjkgjasdkjgasdk
<a>test</a>lol
<a>am</a>
asdhjfgasdjkgdaskj
<a>bfasjdg as</a>
abab';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);