import Foundation
let pattern = #"(<a>.*<\/a>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
asldjkgjasdkjgasdk
<a>test</a>lol
<a>am</a>
asdhjfgasdjkgdaskj
<a>bfasjdg as</a>
abab
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}