re = /(<a>.*<\/a>)/
str = 'asldjkgjasdkjgasdk
<a>test</a>lol
<a>am</a>
asdhjfgasdjkgdaskj
<a>bfasjdg as</a>
abab'
# Print the match result
str.match(re) do |match|
puts match.to_s
end