package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<a>.*<\/a>)`)
var str = `asldjkgjasdkjgasdk
<a>test</a>lol
<a>am</a>
asdhjfgasdjkgdaskj
<a>bfasjdg as</a>
abab`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}