# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/-?0+\.(0)+\b|\.0+\b|\b0+(?=\.\d*[1-9])|\b0+(?=[1-9]\d*\.)|(\.\d*?)0+\b/$1$2/g;t' <<< "00.00
00002.0
3.00
-4.0
0.00
-0.00
0.03
2.01
0.001
-0.03
101
0.001
-0.03
.50
00.00
11.000000"