import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-?0+\\.(0)+\\b|\\.0+\\b|\\b0+(?=\\.\\d*[1-9])|\\b0+(?=[1-9]\\d*\\.)|(\\.\\d*?)0+\\b";
final String string = "00.00\n"
+ "00002.0\n"
+ "3.00\n"
+ "-4.0\n"
+ "0.00\n"
+ "-0.00\n"
+ "0.03\n"
+ "2.01\n"
+ "0.001\n"
+ "-0.03\n"
+ "101\n"
+ "0.001\n"
+ "-0.03\n"
+ ".50\n"
+ "00.00\n"
+ "11.000000";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}