# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*? +//gm;t' <<< "0:- Profile 1
1:- Archetype Realist*in
2:- RIASEC Code: R- Realistic
3:- Subline Deine Stärke? Du bleibst dir selber treu.
4:- Copy Dein Erfolg basiert auf deiner praktischen Ver..."