import re
regex = re.compile(r"^.*? +", flags=re.MULTILINE)
test_str = ("0:- Profile 1\n"
"1:- Archetype Realist*in\n"
"2:- RIASEC Code: R- Realistic\n"
"3:- Subline Deine Stärke? Du bleibst dir selber treu.\n"
"4:- Copy Dein Erfolg basiert auf deiner praktischen Ver...")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)