use strict;
my $str = '0:- Profile 1
1:- Archetype Realist*in
2:- RIASEC Code: R- Realistic
3:- Subline Deine Stärke? Du bleibst dir selber treu.
4:- Copy Dein Erfolg basiert auf deiner praktischen Ver...';
my $regex = qr/^.*? +/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";