import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*? +";
final String string = "0:- Profile 1\n"
+ "1:- Archetype Realist*in\n"
+ "2:- RIASEC Code: R- Realistic\n"
+ "3:- Subline Deine Stärke? Du bleibst dir selber treu.\n"
+ "4:- Copy Dein Erfolg basiert auf deiner praktischen Ver...";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}