using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/[a-z\.]+.kaspersky-labs\.com\/[0-9A-Z\-]+\/main\.js";
string input = @"https://gc.kis.scr.kaspersky-labs.com/3AB9A552-5B01-8648-A873-82DD69063EB6/main.js";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}