re = /https:\/\/[a-z\.]+.kaspersky-labs\.com\/[0-9A-Z\-]+\/main\.js/
str = 'https://gc.kis.scr.kaspersky-labs.com/3AB9A552-5B01-8648-A873-82DD69063EB6/main.js'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end